Forumsee logo
Forumsee » Photography » Film Photography » Read message
RSS: Subscribe to RSS

White blotches on my developed negatives

Medium Format & Large Format - www.thephotoforum.com
So a long time back I dabbled shooting in digital and when I recently considered picking the camera back up again, I thought - no that would be too easy so bought a Hasselblad 503CX and began my first roll in B&W.

Today I developed them, and there are some basic errors in the shots and some things I know I caused in a clumsy first attempt at developing. I used a dark bag and a patterson dev tank.

I can give more specifics on the fixer, developer, photo-flo etc but I feel like this is something I did wrong in terms of timing or technique but upon searching the internet I wasn't able to find any simple explanation for why this happened.

Is anyone able to diagnose this?

Appreciate the support!

 

Attached Files:

-



Read responses in thephotoforum.com

Tags


Last videos:

Something for Nikon D3300 users.
Something for Nikon D3300 users.
4K 60P and Slow Motion
4K 60P and Slow Motion
I'm a YouTube Poet
I'm a YouTube Poet
Happy Holidays, from an Airport
Happy Holidays, from an Airport
Printing Tutorials
Printing Tutorials
Sony a7R III
Sony a7R III
HSS and Flash Meters
HSS and Flash Meters
Documentaries on LF photography
Documentaries on LF photography
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more