Forumsee logo
Forumsee » Photography » Cameras and Equipment » Read message
RSS: Subscribe to RSS

Unusual fuji problems?

Fujifilm - www.clubsnap.com
Have encountered some unusual problems with my X-T10, was wondering if anyone had encountered them too and what is the servicing charge like?

1. one of the metal camera strap lug came loose. It's shaking loosely but still attached but I don't want to leave a camera hanging by the strap. Never dropped or knocked so maybe it was due to some pressure inside a camera bag.

2. 1 speck of dust inside the camera sensor. PRobably between the glass and the sensor, not on its surface. Not noticeable at 1.4-2, but from 2.8 onwards it becomes very visible on every photo. The automatic sensor cleaning doesn't do a thing for this.

I'm guessing servicing on the second one will cost a lot, has anyone serviced before for this?


Read responses in clubsnap.com

Tags


Last videos:

Something for Nikon D3300 users.
Something for Nikon D3300 users.
4K 60P and Slow Motion
4K 60P and Slow Motion
I'm a YouTube Poet
I'm a YouTube Poet
Happy Holidays, from an Airport
Happy Holidays, from an Airport
Printing Tutorials
Printing Tutorials
Sony a7R III
Sony a7R III
HSS and Flash Meters
HSS and Flash Meters
Documentaries on LF photography
Documentaries on LF photography
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more