Forumsee logo
Forumsee » Photography » Cameras and Equipment » Read message
RSS: Subscribe to RSS

Sync Problem with Canon 80D and AB800

Accessories - Filters, Bags, Tripods Forum - photo.net - photo.net
Hi All,

I’m having a problem with syncing my Canon 80D to my Alien Bee B800. I have the AB standard 15-foot sync cord going from the 80D (with a hot shoe adapter mounted) directly to the B800. One night all was well but the next night the unit failed to flash. I switched out the B800 with a 2nd unit and also used both a different sync cord and hot shoe adapter to no avail. I know the flash is not defective because I can manually release it using the flash test button. I made sure all connections were firm.

Could it be that somewhere in the process I inadvertently disabled something in the 80D’s menu system?

Any suggestions?

Thanks in advance.

 


Read responses in photo.net

Tags


Last videos:

I'm a YouTube Poet
I'm a YouTube Poet
Happy Holidays, from an Airport
Happy Holidays, from an Airport
Printing Tutorials
Printing Tutorials
Sony a7R III
Sony a7R III
HSS and Flash Meters
HSS and Flash Meters
Documentaries on LF photography
Documentaries on LF photography
4K 60p Panasonic GH5 thread
4K 60p Panasonic GH5 thread
Insane drone video with Samsung 360 cameras !
Insane drone video with Samsung 360 cameras !
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more