Forumsee logo
Forumsee » Photography » General » Read message
RSS: Subscribe to RSS

Problem with Mamiya 645

Medium Format Photography forum from Photo.net - photo.net
I have a Mamiya 645 I purchased a while back. The problem is when advancing the film it doesn't stop at the next frame, there is a click the shutter is released and it continues to advance. The film advances, the mirror flips up and the shutter open and shuts without pushing the shutter button. The film advance knob seems to trip the shutter somehow? The film counted does advance each time but the mirror stays up sometimes or flips back down while advancing the film. I was wondering if anyone has had this problem and if so how to fix the problem? I don't think it's the insert because I have tried another insert and it still has the problem.

Thanks for the help in advance!


Read responses in photo.net

Tags


Last videos:

Something for Nikon D3300 users.
Something for Nikon D3300 users.
4K 60P and Slow Motion
4K 60P and Slow Motion
I'm a YouTube Poet
I'm a YouTube Poet
Happy Holidays, from an Airport
Happy Holidays, from an Airport
Printing Tutorials
Printing Tutorials
Sony a7R III
Sony a7R III
HSS and Flash Meters
HSS and Flash Meters
Documentaries on LF photography
Documentaries on LF photography
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more