Forumsee logo
Forumsee » Photography » Cameras and Equipment » Read message
RSS: Subscribe to RSS

A300 battery problem?

Sony & Konica Minolta - forums.photographyreview.com
I am having a problem and I was wondering if maybe someone could help me understand what is going on.

I have had my a300 for over a year and love it. On a photo shoot at the end of May (it was very hot out - in the low 100s) my batteries started displaying that it was exhausted. I had to keep switching from one to the other to finish the shoot. I haven't done much with the camera since then but every time I put either of my two batteries in the camera it allows me to take a few pictures telling me I have something like 93% battery life then it quickly shows the white battery exhausted screen.and I can't take any pictures.

I don't know why this is happening. I don't think its my charger since it is displaying that my batteries are charging fully. I am starting to worry its the camera not the batteries. Has anyone else experienced this? Its driving me crazy and I am afraid to book anything else until I get this issue resolved. ANY help would be greatly appreciated!


Read responses in forums.photographyreview.com

Tags


Last videos:

Something for Nikon D3300 users.
Something for Nikon D3300 users.
4K 60P and Slow Motion
4K 60P and Slow Motion
I'm a YouTube Poet
I'm a YouTube Poet
Happy Holidays, from an Airport
Happy Holidays, from an Airport
Printing Tutorials
Printing Tutorials
Sony a7R III
Sony a7R III
HSS and Flash Meters
HSS and Flash Meters
Documentaries on LF photography
Documentaries on LF photography
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more