Forumsee logo
Forumsee » Photography » Image processing » Read message
RSS: Subscribe to RSS

Strange splotches in my developed color negatives... help?

Film processing forum from Photo.net - photo.net
Hi all,

I recently began shooting film in a couple of rangefinders and as part of that effort I've also decided to try my hand at developing film at home.

I've shot a couple of test rolls over the past few weeks but every time I go to develop them I'm getting these weird splotches in my color negatives (scanned w/ an epson v300 flatbed scanner).

A bit of background on my process... I'm using Unicolor's C41 developer kit with a Paterson tank system.

To keep things at the proper temp, I'm using a heated water bath where I put all the containers of chemistry.

I use a timer app on my tablet with a series of timers for each step of the process.

[FONT=Verdana, Geneva, Arial, Helvetica, sans-serif]

Any help / insights on what I might be doing wrong is greatlly appreciated.

TIA!

Ray[/FONT]

 
Date: Apr 20, 2017   


Last videos:

Printing Tutorials
Printing Tutorials
Printing Tutorials
Printing Tutorials
Printing Tutorials
Printing Tutorials
Cave diving video - shot on gopro 5 - fully edited in iphone Quik stories
Cave diving video - shot on gopro 5 - fully edited in iphone Quik stories
Another Lembeh Video
Another Lembeh Video
Uranotype video
Uranotype video
Different Techniques
Different Techniques
Different Techniques
Different Techniques

Tags

Cars ·
Travel ·
Pets ·
production-frontend