Forumsee logo
Forumsee » Photography » Cameras and Equipment » Read message
RSS: Subscribe to RSS

Fujifilm - Unusual fuji problems?

Fujifilm - www.clubsnap.com
Have encountered some unusual problems with my X-T10, was wondering if anyone had encountered them too and what is the servicing charge like?

1. one of the metal camera strap lug came loose. It's shaking loosely but still attached but I don't want to leave a camera hanging by the strap. Never dropped or knocked so maybe it was due to some pressure inside a camera bag.

2. 1 speck of dust inside the camera sensor. PRobably between the glass and the sensor, not on its surface. Not noticeable at 1.4-2, but from 2.8 onwards it becomes very visible on every photo. The automatic sensor cleaning doesn't do a thing for this.

I'm guessing servicing on the second one will cost a lot, has anyone serviced before for this?
Date: May 14, 2017    Labels: Fujifilm


Last videos:

Chris Nicollos from the Camera store previews the D850
Chris Nicollos from the Camera store previews the D850
Chris Nicollos from the Camera store previews the D850
Chris Nicollos from the Camera store previews the D850
Jared Polin - looks at the D850 Raw files IQ
Jared Polin - looks at the D850 Raw files IQ
Aurora 2018 for PC
Aurora 2018 for PC
4K 60P: Runners and Running on the Hudson
4K 60P: Runners and Running on the Hudson
6K Sony VENICE E mount camera !
6K Sony VENICE E mount camera !
6K Sony VENICE E mount camera !
6K Sony VENICE E mount camera !
6K Sony VENICE E mount camera !
6K Sony VENICE E mount camera !

Tags

Cars ·
Travel ·
Pets ·
production-frontend