Forumsee logo
Forumsee » Photography » Cameras and Equipment » Read message
RSS: Subscribe to RSS

Loose lens mount

Canon - www.clubsnap.com
Just wanted to ask fellow experienced photographers, has anyone encountered the lens mount on the body becoming loose after a few years? The mount on my new 7D II has a little tension to it when mounting lenses (about the last 3/4 of the turn before it clicks in place), but on my older 700D which I've had for 4 years now, any lens will just slide and click in place. In terms of how secure the fit is, they are both more or less equally secure, but just that when mounting the 700D offers no resistance at all in the turning motion.

Just mildly concerned, so I was wondering if anyone has similar experiences, or perhaps suggestions. Should I leave it be? Or perhaps should I send it to Canon for them to take a look? Thanks in advance
Date: May 19, 2017   


Tags


Last videos:

Happy Holidays, from an Airport
Happy Holidays, from an Airport
Printing Tutorials
Printing Tutorials
Sony a7R III
Sony a7R III
HSS and Flash Meters
HSS and Flash Meters
Documentaries on LF photography
Documentaries on LF photography
4K 60p Panasonic GH5 thread
4K 60p Panasonic GH5 thread
Insane drone video with Samsung 360 cameras !
Insane drone video with Samsung 360 cameras !
Kodak Ektra - finally something interesting from Kodak
Kodak Ektra - finally something interesting from Kodak
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
About Forumsee · Contact · Privacy policy · Request content removal
production-frontend
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more